Defender-DeviceNetworkEvents

ActionTypeTitleSampleRule
ConnectionSuccessConnection succeededYY
ConnectionFailedConnection failedYY
InboundConnectionAcceptedInbound connection acceptedYY
ListeningConnectionCreatedListening connection createdYY
ConnectionRequestConnection requestNY
DnsConnectionInspectedDNS connection inspectedYN
ConnectionAttemptConnection attemptYY
ConnectionFoundConnection foundYN
NetworkSignatureInspectedNetwork signature inspectedYY
ConnectionAcknowledgedConnection acknowledgedYN
FtpConnectionInspectedFTP connection inspectedNN
HttpConnectionInspectedHTTP connection inspectedYN
IcmpConnectionInspectedICMP connection inspectedYN
InboundInternetScanInspectedInbound internet scan inspectedNN
NtlmAuthenticationInspectedNTLM authentication inspectedYN
SmtpConnectionInspectedSMTP connection inspectedNN
SshConnectionInspectedSSH connection inspectedNN
SslConnectionInspectedSSL connection inspectedYN
KerberosConnectionInspectedKerberos connection inspectedYN

ConnectionSuccess: Connection succeeded

#
Table
DeviceNetworkEvents

Detection Fields #

Fields referenced by at least one attached detection rule. This view counts distinct rules and is not a complete schema for this catalog entry.

NameRulesVendors
ActionType13 detection rulesKusto
RemotePort6 detection rulesKusto
InitiatingProcessFileName4 detection rulesKusto
RemoteUrl4 detection rulesKusto
RemoteIP3 detection rulesKusto
RemoteIPType3 detection rulesKusto
DeviceId1 detection ruleKusto
DeviceName1 detection ruleKusto
InitiatingProcessCommandLine1 detection ruleKusto
InitiatingProcessFolderPath1 detection ruleKusto
InitiatingProcessParentFileName1 detection ruleKusto
InitiatingProcessSHA2561 detection ruleKusto
LocalIP1 detection ruleKusto

Example Event #

{
  "ActionType": "ConnectionSuccess",
  "DeviceId": "99ffb4eafd9c8fb310527d15d666a58ab4661114",
  "DeviceName": "jd-win11-22h2-1.ludus.domain",
  "InitiatingProcessAccountDomain": "nt authority",
  "InitiatingProcessAccountName": "network service",
  "InitiatingProcessAccountSid": "S-1-5-20",
  "InitiatingProcessCommandLine": "svchost.exe -k NetworkService -p",
  "InitiatingProcessCreationTime": "2026-08-01T00:56:39.0752007Z",
  "InitiatingProcessFileName": "svchost.exe",
  "InitiatingProcessFileSize": 79920,
  "InitiatingProcessFileSize@odata.type": "#Int64",
  "InitiatingProcessFolderPath": "c:\\windows\\system32\\svchost.exe",
  "InitiatingProcessId": 1540,
  "InitiatingProcessId@odata.type": "#Int64",
  "InitiatingProcessIntegrityLevel": "System",
  "InitiatingProcessMD5": "8ec922c7a58a8701ab481b7be9644536",
  "InitiatingProcessParentCreationTime": "2026-08-01T00:56:34.7240107Z",
  "InitiatingProcessParentFileName": "services.exe",
  "InitiatingProcessParentId": 1084,
  "InitiatingProcessParentId@odata.type": "#Int64",
  "InitiatingProcessSHA1": "3f64c98f22da277a07cab248c44c56eedb796a81",
  "InitiatingProcessSHA256": "949bfb5b4c7d58d92f3f9c5f8ec7ca4ceaffd10ec5f0020f0a987c472d61c54b",
  "InitiatingProcessSessionId": 0,
  "InitiatingProcessSessionId@odata.type": "#Int64",
  "InitiatingProcessTokenElevation": "TokenElevationTypeDefault",
  "InitiatingProcessUniqueId": "9851624184872980",
  "InitiatingProcessVersionInfoCompanyName": "Microsoft Corporation",
  "InitiatingProcessVersionInfoFileDescription": "Host Process for Windows Services",
  "InitiatingProcessVersionInfoInternalFileName": "svchost.exe",
  "InitiatingProcessVersionInfoOriginalFileName": "svchost.exe",
  "InitiatingProcessVersionInfoProductName": "Microsoft® Windows® Operating System",
  "InitiatingProcessVersionInfoProductVersion": "10.0.22621.1",
  "IsInitiatingProcessRemoteSession": 0,
  "IsInitiatingProcessRemoteSession@odata.type": "#SByte",
  "LocalIP": "10.2.10.21",
  "LocalPort": 50334,
  "Protocol": "TcpV4",
  "RemoteIP": "203.0.113.10",
  "RemotePort": 80,
  "RemoteUrl": "http://ctldl.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab?e129dbb8d60525cc",
  "ReportId": 14416,
  "ReportId@odata.type": "#Int64",
  "Timestamp": "2026-08-01T09:28:25.0297813Z"
}

Detection Patterns #

Show All Detection Patterns

Common Indicators #

Positive field/value combinations most frequently checked by detection rules attached to this catalog entry, derived from cross-vendor predicate analysis. This is separate from Fields accounting, which also includes exclusions and counts distinct attached rules.

FieldKindValueRulesVendors
ActionType (kusto rule field)eqConnectionSuccess4 ruleskusto
DestinationPort (kusto rule field)in4451 rulekusto
RemoteIPType (kusto rule field)eqPublic1 rulekusto
process_basename (kusto rule field)eqmstsc.exe1 rulekusto

Detection Rules #

Full rule details for this catalog entry, including ATT&CK technique mappings and native queries →

Kusto #

ConnectionFailed: Connection failed

#
Table
DeviceNetworkEvents

Detection Fields #

Fields referenced by at least one attached detection rule. This view counts distinct rules and is not a complete schema for this catalog entry.

NameRulesVendors
ActionType1 detection ruleKusto
InitiatingProcessSHA2561 detection ruleKusto
RemotePort1 detection ruleKusto

Example Event #

{
  "ActionType": "ConnectionFailed",
  "DeviceId": "ec2cc6b53848cc3454a79df3684465dee27fec8c",
  "DeviceName": "jd-dc01-2022.ludus.domain",
  "InitiatingProcessAccountDomain": "nt authority",
  "InitiatingProcessAccountName": "system",
  "InitiatingProcessAccountSid": "S-1-5-18",
  "InitiatingProcessCommandLine": "spoolsv.exe",
  "InitiatingProcessCreationTime": "2026-08-01T01:02:25.79631Z",
  "InitiatingProcessFileName": "spoolsv.exe",
  "InitiatingProcessFileSize": 888832,
  "InitiatingProcessFileSize@odata.type": "#Int64",
  "InitiatingProcessFolderPath": "c:\\windows\\system32\\spoolsv.exe",
  "InitiatingProcessId": 4564,
  "InitiatingProcessId@odata.type": "#Int64",
  "InitiatingProcessIntegrityLevel": "System",
  "InitiatingProcessMD5": "16606819f6aab105221ab02b5d4dd7a2",
  "InitiatingProcessParentCreationTime": "2026-08-01T01:02:12.0633947Z",
  "InitiatingProcessParentFileName": "services.exe",
  "InitiatingProcessParentId": 1232,
  "InitiatingProcessParentId@odata.type": "#Int64",
  "InitiatingProcessSHA1": "9b2bd60bf0c302fdb7cc1c3cec3c1e9caeb3f803",
  "InitiatingProcessSHA256": "f6c4f2d9b408783fee17f260b6b9002806f5305543c8f3161fa0e3ca87588fc5",
  "InitiatingProcessSessionId": 0,
  "InitiatingProcessSessionId@odata.type": "#Int64",
  "InitiatingProcessTokenElevation": "TokenElevationTypeDefault",
  "InitiatingProcessUniqueId": "7318349394477133",
  "InitiatingProcessVersionInfoCompanyName": "Microsoft Corporation",
  "InitiatingProcessVersionInfoFileDescription": "Spooler SubSystem App",
  "InitiatingProcessVersionInfoInternalFileName": "spoolsv.exe",
  "InitiatingProcessVersionInfoOriginalFileName": "spoolsv.exe",
  "InitiatingProcessVersionInfoProductName": "Microsoft® Windows® Operating System",
  "InitiatingProcessVersionInfoProductVersion": "10.0.20348.4294",
  "IsInitiatingProcessRemoteSession": 0,
  "IsInitiatingProcessRemoteSession@odata.type": "#SByte",
  "LocalIP": "::1",
  "LocalIPType": "Loopback",
  "LocalPort": 51310,
  "Protocol": "Tcp",
  "RemoteIP": "::1",
  "RemoteIPType": "Loopback",
  "RemotePort": 389,
  "ReportId": 1057911,
  "ReportId@odata.type": "#Int64",
  "Timestamp": "2026-08-01T09:02:28.2177291Z"
}

Detection Patterns #

Common Indicators #

Positive field/value combinations most frequently checked by detection rules attached to this catalog entry, derived from cross-vendor predicate analysis. This is separate from Fields accounting, which also includes exclusions and counts distinct attached rules.

FieldKindValueRulesVendors
DestinationPort (kusto rule field)in4451 rulekusto

InboundConnectionAccepted: Inbound connection accepted

#
Table
DeviceNetworkEvents

Detection Fields #

Fields referenced by at least one attached detection rule. This view counts distinct rules and is not a complete schema for this catalog entry.

NameRulesVendors
ActionType5 detection rulesKusto
InitiatingProcessFileName2 detection rulesKusto
LocalPort1 detection ruleKusto
RemoteIP1 detection ruleKusto
RemoteIPType1 detection ruleKusto

Example Event #

{
  "ActionType": "InboundConnectionAccepted",
  "DeviceId": "99ffb4eafd9c8fb310527d15d666a58ab4661114",
  "DeviceName": "jd-win11-22h2-1.ludus.domain",
  "InitiatingProcessAccountDomain": "nt authority",
  "InitiatingProcessAccountName": "system",
  "InitiatingProcessAccountSid": "S-1-5-18",
  "InitiatingProcessCreationTime": "2026-08-01T00:56:23.4789618Z",
  "InitiatingProcessFileName": "ntoskrnl.exe",
  "InitiatingProcessFileSize": 12080544,
  "InitiatingProcessFileSize@odata.type": "#Int64",
  "InitiatingProcessFolderPath": "c:\\windows\\system32\\ntoskrnl.exe",
  "InitiatingProcessId": 4,
  "InitiatingProcessId@odata.type": "#Int64",
  "InitiatingProcessIntegrityLevel": "System",
  "InitiatingProcessMD5": "7f51b4fec9c32bcb910365ce68ae492e",
  "InitiatingProcessParentId": 0,
  "InitiatingProcessParentId@odata.type": "#Int64",
  "InitiatingProcessSHA1": "a92ba6de8966d5b1f0866951832e8ca62ebe6129",
  "InitiatingProcessSHA256": "3255a69b65c23e1356b247aa8c05e93f6a4868268c878952af60c520d887596b",
  "InitiatingProcessSessionId": 0,
  "InitiatingProcessSessionId@odata.type": "#Int64",
  "InitiatingProcessTokenElevation": "TokenElevationTypeDefault",
  "InitiatingProcessUniqueId": "9851624184872961",
  "InitiatingProcessVersionInfoCompanyName": "Microsoft Corporation",
  "InitiatingProcessVersionInfoFileDescription": "NT Kernel & System",
  "InitiatingProcessVersionInfoInternalFileName": "ntkrnlmp.exe",
  "InitiatingProcessVersionInfoOriginalFileName": "ntkrnlmp.exe",
  "InitiatingProcessVersionInfoProductName": "Microsoft® Windows® Operating System",
  "InitiatingProcessVersionInfoProductVersion": "10.0.22621.6060",
  "IsInitiatingProcessRemoteSession": 0,
  "IsInitiatingProcessRemoteSession@odata.type": "#SByte",
  "LocalIP": "::ffff:10.2.10.21",
  "LocalIPType": "FourToSixMapping",
  "LocalPort": 5986,
  "Protocol": "Tcp",
  "RemoteIP": "::ffff:10.2.20.61",
  "RemoteIPType": "FourToSixMapping",
  "RemotePort": 48428,
  "ReportId": 5592,
  "ReportId@odata.type": "#Int64",
  "Timestamp": "2026-08-01T08:16:59.4820229Z"
}

Detection Patterns #

Common Indicators #

Positive field/value combinations most frequently checked by detection rules attached to this catalog entry, derived from cross-vendor predicate analysis. This is separate from Fields accounting, which also includes exclusions and counts distinct attached rules.

FieldKindValueRulesVendors
RemoteIPType (kusto rule field)eqPublic1 rulekusto
process_basename (kusto rule field)eqmsiexec.exe1 rulekusto

Detection Rules #

Full rule details for this catalog entry, including ATT&CK technique mappings and native queries →

Kusto #

ListeningConnectionCreated: Listening connection created

#
Table
DeviceNetworkEvents

Detection Fields #

Fields referenced by at least one attached detection rule. This view counts distinct rules and is not a complete schema for this catalog entry.

NameRulesVendors
ActionType3 detection rulesKusto
InitiatingProcessCommandLine2 detection rulesKusto
InitiatingProcessParentFileName2 detection rulesKusto
DeviceName1 detection ruleKusto
InitiatingProcessFileName1 detection ruleKusto
LocalIP1 detection ruleKusto
LocalPort1 detection ruleKusto
RemotePort1 detection ruleKusto

Example Event #

{
  "ActionType": "ListeningConnectionCreated",
  "DeviceId": "99ffb4eafd9c8fb310527d15d666a58ab4661114",
  "DeviceName": "jd-win11-22h2-1.ludus.domain",
  "InitiatingProcessAccountDomain": "ludus",
  "InitiatingProcessAccountName": "domainadmin",
  "InitiatingProcessAccountObjectId": "11111111-1111-1111-1111-111111111111",
  "InitiatingProcessAccountSid": "S-1-5-21-1006758700-2167138679-1475694448-1105",
  "InitiatingProcessAccountUpn": "adminuser@example.onmicrosoft.com",
  "InitiatingProcessCommandLine": "silentConfig",
  "InitiatingProcessCreationTime": "2026-08-01T08:03:14.4564803Z",
  "InitiatingProcessFileName": "onedrive.sync.service.exe",
  "InitiatingProcessFileSize": 958824,
  "InitiatingProcessFileSize@odata.type": "#Int64",
  "InitiatingProcessFolderPath": "c:\\program files\\microsoft onedrive\\26.108.0607.0002\\onedrive.sync.service.exe",
  "InitiatingProcessId": 4008,
  "InitiatingProcessId@odata.type": "#Int64",
  "InitiatingProcessIntegrityLevel": "High",
  "InitiatingProcessMD5": "fee3b832738170231cce3a3786255fcc",
  "InitiatingProcessParentCreationTime": "2026-08-01T08:02:22.9601643Z",
  "InitiatingProcessParentFileName": "OneDriveStandaloneUpdater.exe",
  "InitiatingProcessParentId": 1524,
  "InitiatingProcessParentId@odata.type": "#Int64",
  "InitiatingProcessSHA1": "cca7a5db29e641d055964c56c40639752ee587ee",
  "InitiatingProcessSHA256": "c19e82597361c901ec1378203476953e227c0fa0589448bf065e2026b9330af1",
  "InitiatingProcessSessionId": 1,
  "InitiatingProcessSessionId@odata.type": "#Int64",
  "InitiatingProcessTokenElevation": "TokenElevationTypeDefault",
  "InitiatingProcessUniqueId": "9851624184873396",
  "InitiatingProcessVersionInfoCompanyName": "Microsoft Corporation",
  "InitiatingProcessVersionInfoFileDescription": "Microsoft OneDrive Sync Service",
  "InitiatingProcessVersionInfoInternalFileName": "Client Application",
  "InitiatingProcessVersionInfoOriginalFileName": "OneDrive.Sync.Service.exe",
  "InitiatingProcessVersionInfoProductName": "Microsoft OneDrive Sync Service",
  "InitiatingProcessVersionInfoProductVersion": "26.108.0607.0002",
  "IsInitiatingProcessRemoteSession": 0,
  "IsInitiatingProcessRemoteSession@odata.type": "#SByte",
  "LocalIP": "::1",
  "LocalPort": 42050,
  "Protocol": "TcpV6",
  "ReportId": 1882,
  "ReportId@odata.type": "#Int64",
  "Timestamp": "2026-08-01T08:03:18.2539581Z"
}

Common Indicators #

Positive field/value combinations most frequently checked by detection rules attached to this catalog entry, derived from cross-vendor predicate analysis. This is separate from Fields accounting, which also includes exclusions and counts distinct attached rules.

FieldKindValueRulesVendors
process_basename (kusto rule field)inChrome.exe1 rulekusto
process_basename (kusto rule field)inmsedge.exe1 rulekusto

Detection Rules #

Full rule details for this catalog entry, including ATT&CK technique mappings and native queries →

Kusto #

ConnectionRequest: Connection request

#
Table
DeviceNetworkEvents

Detection Fields #

Fields referenced by at least one attached detection rule. This view counts distinct rules and is not a complete schema for this catalog entry.

NameRulesVendors
ActionType1 detection ruleKusto
InitiatingProcessSHA2561 detection ruleKusto
RemotePort1 detection ruleKusto

Detection Patterns #

Common Indicators #

Positive field/value combinations most frequently checked by detection rules attached to this catalog entry, derived from cross-vendor predicate analysis. This is separate from Fields accounting, which also includes exclusions and counts distinct attached rules.

FieldKindValueRulesVendors
DestinationPort (kusto rule field)in4451 rulekusto

DnsConnectionInspected: DNS connection inspected

#
Table
DeviceNetworkEvents

Example Event #

{
  "ActionType": "DnsConnectionInspected",
  "AdditionalFields": {
    "direction": "Out",
    "trans_id": "59777",
    "query": "203.0.113.10.in-addr.arpa",
    "qclass": "1",
    "qclass_name": "C_INTERNET",
    "qtype": "12",
    "qtype_name": "PTR",
    "rcode": "3",
    "uid": "CUEMHp2Rts8bFPR0H9",
    "rcode_name": "NXDOMAIN",
    "AA": "false",
    "TC": "false",
    "RD": "true",
    "RA": "false",
    "rejected": "false",
    "ts": "134300497761197320"
  },
  "DeviceId": "99ffb4eafd9c8fb310527d15d666a58ab4661114",
  "DeviceName": "jd-win11-22h2-1.ludus.domain",
  "InitiatingProcessId": 0,
  "InitiatingProcessId@odata.type": "#Int64",
  "InitiatingProcessParentId": 0,
  "InitiatingProcessParentId@odata.type": "#Int64",
  "InitiatingProcessTokenElevation": "None",
  "InitiatingProcessUniqueId": "0",
  "IsInitiatingProcessRemoteSession": 0,
  "IsInitiatingProcessRemoteSession@odata.type": "#SByte",
  "LocalIP": "10.2.10.21",
  "LocalPort": 57469,
  "Protocol": "Udp",
  "RemoteIP": "10.2.10.11",
  "RemotePort": 53,
  "ReportId": 14406,
  "ReportId@odata.type": "#Int64",
  "Timestamp": "2026-08-01T09:23:02.1498305Z"
}

ConnectionAttempt: Connection attempt

#
Table
DeviceNetworkEvents

Detection Fields #

Fields referenced by at least one attached detection rule. This view counts distinct rules and is not a complete schema for this catalog entry.

NameRulesVendors
ActionType1 detection ruleKusto
InitiatingProcessSHA2561 detection ruleKusto
RemotePort1 detection ruleKusto

Example Event #

{
  "ActionType": "ConnectionAttempt",
  "AdditionalFields": {
    "direction": "In",
    "Source Mac": "bc:24:11:9a:4d:c2",
    "Destination Mac": "bc:24:11:22:5b:57",
    "Tcp Flags": 2,
    "Packet Size": 74
  },
  "DeviceId": "99ffb4eafd9c8fb310527d15d666a58ab4661114",
  "DeviceName": "jd-win11-22h2-1.ludus.domain",
  "InitiatingProcessId": 0,
  "InitiatingProcessId@odata.type": "#Int64",
  "InitiatingProcessParentId": 0,
  "InitiatingProcessParentId@odata.type": "#Int64",
  "InitiatingProcessTokenElevation": "None",
  "InitiatingProcessUniqueId": "0",
  "IsInitiatingProcessRemoteSession": 0,
  "IsInitiatingProcessRemoteSession@odata.type": "#SByte",
  "LocalIP": "10.2.10.21",
  "LocalPort": 5986,
  "Protocol": "TcpV4",
  "RemoteIP": "10.2.20.61",
  "RemotePort": 48428,
  "ReportId": 5639,
  "ReportId@odata.type": "#Int64",
  "Timestamp": "2026-08-01T08:17:01.5483472Z"
}

Detection Patterns #

Common Indicators #

Positive field/value combinations most frequently checked by detection rules attached to this catalog entry, derived from cross-vendor predicate analysis. This is separate from Fields accounting, which also includes exclusions and counts distinct attached rules.

FieldKindValueRulesVendors
DestinationPort (kusto rule field)in4451 rulekusto

ConnectionFound: Connection found

#
Table
DeviceNetworkEvents

Example Event #

{
  "ActionType": "ConnectionFound",
  "DeviceId": "99ffb4eafd9c8fb310527d15d666a58ab4661114",
  "DeviceName": "jd-win11-22h2-1.ludus.domain",
  "InitiatingProcessFileName": "OneDriveSetup.exe",
  "InitiatingProcessFolderPath": "C:\\Program Files\\Microsoft OneDrive\\StandaloneUpdater\\OneDriveSetup.exe",
  "InitiatingProcessId": 0,
  "InitiatingProcessId@odata.type": "#Int64",
  "InitiatingProcessParentId": 0,
  "InitiatingProcessParentId@odata.type": "#Int64",
  "InitiatingProcessTokenElevation": "None",
  "InitiatingProcessUniqueId": "0",
  "IsInitiatingProcessRemoteSession": 0,
  "IsInitiatingProcessRemoteSession@odata.type": "#SByte",
  "LocalIP": "::ffff:10.2.10.21",
  "LocalPort": 56414,
  "Protocol": "Tcp",
  "RemoteIP": "::ffff:203.0.113.10",
  "RemotePort": 443,
  "ReportId": 2180127561,
  "ReportId@odata.type": "#Int64",
  "Timestamp": "2026-08-01T08:03:15.1962246Z"
}

NetworkSignatureInspected: Network signature inspected

#
Table
DeviceNetworkEvents

Detection Fields #

Fields referenced by at least one attached detection rule. This view counts distinct rules and is not a complete schema for this catalog entry.

NameRulesVendors
ActionType2 detection rulesKusto

Example Event #

{
  "ActionType": "NetworkSignatureInspected",
  "AdditionalFields": {
    "SignatureName": "Kerberos_TGS_REQ",
    "SignatureMatchedContent": "%05¢%03%02%01%0C",
    "SamplePacketContent": [
      "u~%0F“_%80‰.ãŸÂ%02óºl¶Âaºç÷>%7Fc%10ÃêìÞó§VQ×>´%17F%1D>%0C¼í`%01o@%90¸ÑTâòï÷4%1A%03\"욲%0AóhBMïß%99Ӟh%15ô%0A\tЗ$é3,ÒZ%01òrî¯6%8F/›ÀڗJŠ%80+`üô×Òca%1C!¶Cx¥%8D«’µ1Z%99ã¿%07­·LJ¦’xôè?Ñvß^%9D2¯Û%1E2öï%1A½%1CZ’ÁùaýáÂÚ%1FnÂ?ö%99iœ¼%0AÍ; %1E+èG}ü*47T?žph%12L%88 Ñ%80±-¹çƒ¥ œú%02õØFp%99%081œù±S´Õ,%8D‰%10§%00ÊîŸR}%9Dcÿ¡,X*þ%10o“3àè’ëáÜÐU²åÍ>R«%9Dº¸u!%7FY‰-=%03©,¡u´ŠòОU¶Þaøž×f/%1B%0Aʒ^Vd&%90)Á¹G»È!pöb®{kw¢œ%17Ò%07aøühi­Ái·þxè|ØÏI¼%9DoÄÖ%1Ds%99û*Ç%0BÚÅÍÈæ7”\\%0D%98=¥¨4%1DÉqg”%11K6yÂLJØÍÕ5”%13'îvtýƒ$p‹%0DE0wnIƒ+P%1FJ%0Aq%11\\Šá’åxÞ_Áâ.%88±’àæ¯D¹%8DC%1F‰Û³]S&…Ÿz®yY£­ôÊMYþg%0D¬Æ%0B¢;M%81“ó’8¾Éå܎Žô~‰åäk(%88ŠW̃¡Ýq>…%8D>%133c*%15%08ú%08w‘à4oýšC5%88¦ŸÛ–Á%17%00Ùâ%99H<b@tß4Pßgœè¦’%7FlÐoS½¾’Ðà,ë^¹“6%0C&Ä%8Dú%14 H|»<©võ%00%0ESÆfô%019éç“u#xŽì.é%0B9„±ÁQ%1F´:,%7F%17›GP³ªÒ×%0FLò%06…s%13ž%01õ%08ÜRIF%7Fo%01?ã%02Qšöï%0E¶±k%11¡O%1Ažõ%88’ÂÀ%13Š’­Ï/Ûì%01P¤%81 0%81%9D %03%02%01%12¢%81•%04%81’HVýn aZð=<8%05ïùn%80\" KHiáhÐPl^aCý¾Ñý¾¥á›LñC_\"zÓ¼%9D%07ùiÅ¿£¡«ø¹6þ²*ÚCÖ³–A%026…ÌWrF%1B”¾üÓj{%08%115%9D'%19ɹÇË%04\\ãNVé°%0BôÀÄóø†4+%12@G%7F%1D%06”!t%1F8Éé%15꽺ìÍ-e%1E%0Aï›Q½ãìÉ©.Ä¥%0DòáÁ^_0%15¡%04%02%02%00§"
    ]
  },
  "DeviceId": "99ffb4eafd9c8fb310527d15d666a58ab4661114",
  "DeviceName": "jd-win11-22h2-1.ludus.domain",
  "InitiatingProcessId": 0,
  "InitiatingProcessId@odata.type": "#Int64",
  "InitiatingProcessParentId": 0,
  "InitiatingProcessParentId@odata.type": "#Int64",
  "InitiatingProcessTokenElevation": "None",
  "InitiatingProcessUniqueId": "0",
  "IsInitiatingProcessRemoteSession": 0,
  "IsInitiatingProcessRemoteSession@odata.type": "#SByte",
  "LocalIP": "10.2.10.21",
  "LocalPort": 57967,
  "RemoteIP": "10.2.10.11",
  "RemotePort": 88,
  "ReportId": 14289,
  "ReportId@odata.type": "#Int64",
  "Timestamp": "2026-08-01T08:56:53.3394202Z"
}

Detection Patterns #

Detection Rules #

Full rule details for this catalog entry, including ATT&CK technique mappings and native queries →

Kusto #

  • DumpGuard NTLM challenge detected source: With the DumpGuard tool, attackers are able to dump credetials via Remote Credential Guard on devices that have Credential Guard enabled. The creator of the DumpGuard tool purposely used a hard-coded NTLMv1 challenge into the tool, for easy detection. > [!WARNING] > Since the detection relies on a static IOC that can easily be changed in the source code, this detection has a low confidence score since it can be easily bypassed. However, if the detection hits it is almost 100% certain the alert will be TP. > Also take into account that the NetworkSignatureInspected ActionType in MDE is sampled, which means not very event will be logged.T1003, T1003.004

ConnectionAcknowledged: Connection acknowledged

#
Table
DeviceNetworkEvents

Example Event #

{
  "ActionType": "ConnectionAcknowledged",
  "AdditionalFields": {
    "Tcp Flags": 18,
    "direction": "In",
    "Source Mac": "bc:24:11:9a:4d:c2",
    "Destination Mac": "bc:24:11:22:5b:57",
    "Packet Size": 66
  },
  "DeviceId": "99ffb4eafd9c8fb310527d15d666a58ab4661114",
  "DeviceName": "jd-win11-22h2-1.ludus.domain",
  "InitiatingProcessId": 0,
  "InitiatingProcessId@odata.type": "#Int64",
  "InitiatingProcessParentId": 0,
  "InitiatingProcessParentId@odata.type": "#Int64",
  "InitiatingProcessTokenElevation": "None",
  "InitiatingProcessUniqueId": "0",
  "IsInitiatingProcessRemoteSession": 0,
  "IsInitiatingProcessRemoteSession@odata.type": "#SByte",
  "LocalIP": "10.2.10.21",
  "LocalPort": 50326,
  "Protocol": "TcpV4",
  "RemoteIP": "203.0.113.10",
  "RemotePort": 443,
  "ReportId": 14405,
  "ReportId@odata.type": "#Int64",
  "Timestamp": "2026-08-01T09:23:00.1340831Z"
}

FtpConnectionInspected: FTP connection inspected

#
Table
DeviceNetworkEvents

HttpConnectionInspected: HTTP connection inspected

#
Table
DeviceNetworkEvents

Example Event #

{
  "ActionType": "HttpConnectionInspected",
  "AdditionalFields": {
    "direction": "Out",
    "host": "c.pki.goog",
    "method": "GET",
    "request_body_len": "0",
    "response_body_len": "0",
    "status_code": "304",
    "status_msg": "Not Modified",
    "tags": [],
    "trans_depth": "1",
    "uri": "/r/r1.crl",
    "user_agent": "Microsoft-CryptoAPI/10.0",
    "version": "1.1"
  },
  "DeviceId": "99ffb4eafd9c8fb310527d15d666a58ab4661114",
  "DeviceName": "jd-win11-22h2-1.ludus.domain",
  "InitiatingProcessId": 0,
  "InitiatingProcessId@odata.type": "#Int64",
  "InitiatingProcessParentId": 0,
  "InitiatingProcessParentId@odata.type": "#Int64",
  "InitiatingProcessTokenElevation": "None",
  "InitiatingProcessUniqueId": "0",
  "IsInitiatingProcessRemoteSession": 0,
  "IsInitiatingProcessRemoteSession@odata.type": "#SByte",
  "LocalIP": "10.2.10.21",
  "LocalPort": 50305,
  "Protocol": "Tcp",
  "RemoteIP": "203.0.113.10",
  "RemotePort": 80,
  "ReportId": 14365,
  "ReportId@odata.type": "#Int64",
  "Timestamp": "2026-08-01T09:05:01.4264095Z"
}

IcmpConnectionInspected: ICMP connection inspected

#
Table
DeviceNetworkEvents

Example Event #

{
  "ActionType": "IcmpConnectionInspected",
  "AdditionalFields": {
    "conn_state": "OTH",
    "duration": "240.71993613243103",
    "missed_bytes": "0",
    "orig_bytes": "288",
    "orig_ip_bytes": "540",
    "orig_pkts": "9",
    "resp_bytes": "288",
    "resp_ip_bytes": "540",
    "resp_pkts": "9",
    "uid": "CNFHMN3nctbhCAEgB"
  },
  "DeviceId": "99ffb4eafd9c8fb310527d15d666a58ab4661114",
  "DeviceName": "jd-win11-22h2-1.ludus.domain",
  "InitiatingProcessId": 0,
  "InitiatingProcessId@odata.type": "#Int64",
  "InitiatingProcessParentId": 0,
  "InitiatingProcessParentId@odata.type": "#Int64",
  "InitiatingProcessTokenElevation": "None",
  "InitiatingProcessUniqueId": "0",
  "IsInitiatingProcessRemoteSession": 0,
  "IsInitiatingProcessRemoteSession@odata.type": "#SByte",
  "LocalIP": "10.2.10.21",
  "Protocol": "Icmp",
  "RemoteIP": "203.0.113.10",
  "ReportId": 1510,
  "ReportId@odata.type": "#Int64",
  "Timestamp": "2026-08-01T08:02:25.7216344Z"
}

InboundInternetScanInspected: Inbound internet scan inspected

#
Table
DeviceNetworkEvents

NtlmAuthenticationInspected: NTLM authentication inspected

#
Table
DeviceNetworkEvents

Example Event #

{
  "ActionType": "NtlmAuthenticationInspected",
  "AdditionalFields": {
    "direction": "Out",
    "username": "domainadmin",
    "hostname": "JD-WIN11-22H2-1",
    "domainname": "ludus",
    "server_nb_computer_name": "JD-DC01-2022",
    "server_nb_domain_name": "ludus",
    "server_dns_computer_name": "JD-DC01-2022.ludus.domain",
    "server_dns_domain_name": "ludus.domain",
    "server_tree_name": "ludus.domain",
    "uid": "C1udKP14UIrFMpCBbd",
    "success": "true",
    "server_version": "10.0 20348 15",
    "ts": "134300269608386840"
  },
  "DeviceId": "99ffb4eafd9c8fb310527d15d666a58ab4661114",
  "DeviceName": "jd-win11-22h2-1.ludus.domain",
  "InitiatingProcessId": 0,
  "InitiatingProcessId@odata.type": "#Int64",
  "InitiatingProcessParentId": 0,
  "InitiatingProcessParentId@odata.type": "#Int64",
  "InitiatingProcessTokenElevation": "None",
  "InitiatingProcessUniqueId": "0",
  "IsInitiatingProcessRemoteSession": 0,
  "IsInitiatingProcessRemoteSession@odata.type": "#SByte",
  "LocalIP": "10.2.10.21",
  "LocalPort": 59421,
  "Protocol": "Tcp",
  "RemoteIP": "10.2.10.11",
  "RemotePort": 445,
  "ReportId": 8693,
  "ReportId@odata.type": "#Int64",
  "Timestamp": "2026-08-01T03:02:44.060646Z"
}

SmtpConnectionInspected: SMTP connection inspected

#
Table
DeviceNetworkEvents

SshConnectionInspected: SSH connection inspected

#
Table
DeviceNetworkEvents

SslConnectionInspected: SSL connection inspected

#
Table
DeviceNetworkEvents

Example Event #

{
  "ActionType": "SslConnectionInspected",
  "AdditionalFields": {
    "direction": "Out",
    "version": "TLSv12",
    "curve": "x25519",
    "server_name": "edr-cus3.us.endpoint.security.microsoft.com",
    "resumed": "false",
    "next_protocol": "http/1.1",
    "established": "true",
    "subject": "CN=*.endpoint.security.microsoft.com",
    "uid": "CXRdsI15OAFHAOcOyk",
    "issuer": "CN=Microsoft Secure Server CA 2011,O=Microsoft Corporation,L=Redmond,ST=Washington,C=US",
    "cipher": "TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256",
    "ts": "134300492242995840",
    "ja3": "091f51a7a1c3a4504a224cc081ce9cee",
    "ja3s": "00447ab319e9d94ba2b4c1248e155917",
    "ja4": "t12d1809h2_4b22cbed5bed_7af1ed941c26",
    "ja4s": "t1206h1_c02f_17136cd5846b"
  },
  "DeviceId": "99ffb4eafd9c8fb310527d15d666a58ab4661114",
  "DeviceName": "jd-win11-22h2-1.ludus.domain",
  "InitiatingProcessId": 0,
  "InitiatingProcessId@odata.type": "#Int64",
  "InitiatingProcessParentId": 0,
  "InitiatingProcessParentId@odata.type": "#Int64",
  "InitiatingProcessTokenElevation": "None",
  "InitiatingProcessUniqueId": "0",
  "IsInitiatingProcessRemoteSession": 0,
  "IsInitiatingProcessRemoteSession@odata.type": "#SByte",
  "LocalIP": "10.2.10.21",
  "LocalPort": 50314,
  "Protocol": "Tcp",
  "RemoteIP": "203.0.113.10",
  "RemotePort": 443,
  "ReportId": 14392,
  "ReportId@odata.type": "#Int64",
  "Timestamp": "2026-08-01T09:13:46.7211352Z"
}

KerberosConnectionInspected: Kerberos connection inspected

#
Table
DeviceNetworkEvents

Example Event #

{
  "ActionType": "KerberosConnectionInspected",
  "AdditionalFields": {
    "direction": "Out",
    "success": "true",
    "ticketHash": "0b5d1f6b94eb46028099a2f5273db987fb6e3e50de9d05f71b7dbea003bc32e4",
    "cipher": "aes256-cts-hmac-sha1-96",
    "requestType": "AP",
    "service": "cifs/JD-DC01-2022.ludus.domain/LUDUS.DOMAIN",
    "uid": "CIHVyA1HRLPnV44wb3",
    "ts": "134300457424733840"
  },
  "DeviceId": "99ffb4eafd9c8fb310527d15d666a58ab4661114",
  "DeviceName": "jd-win11-22h2-1.ludus.domain",
  "IsInitiatingProcessRemoteSession": 0,
  "IsInitiatingProcessRemoteSession@odata.type": "#SByte",
  "LocalIP": "10.2.10.21",
  "LocalPort": 54559,
  "Protocol": "Kerberos",
  "RemoteIP": "10.2.10.11",
  "RemotePort": 445,
  "ReportId": 5578,
  "ReportId@odata.type": "#Int64",
  "Timestamp": "2026-08-01T08:15:45.2152731Z"
}

any: Network activity

#

Scope grouping: This repository-authored catalog entry represents a broad attribution scope, not a distinct emitted event or operation. Any sample below is a representative record from that scope; attached rules, if any, are listed separately.

Table
DeviceNetworkEvents

Detection Fields #

Fields referenced by at least one attached detection rule. This view counts distinct rules and is not a complete schema for this catalog entry.

NameRulesVendors
ActionType12 detection rulesKusto
RemoteIP8 detection rulesKusto
RemoteUrl6 detection rulesKusto
InitiatingProcessFileName5 detection rulesKusto
RemoteIPType4 detection rulesKusto
InitiatingProcessSHA2563 detection rulesKusto
DeviceName2 detection rulesKusto
InitiatingProcessCommandLine2 detection rulesKusto
InitiatingProcessFolderPath2 detection rulesKusto
InitiatingProcessParentFileName2 detection rulesKusto
LocalPort2 detection rulesKusto
RemotePort2 detection rulesKusto
LocalIP1 detection ruleKusto

Representative record #

{
  "ActionType": "ConnectionSuccess",
  "DeviceId": "99ffb4eafd9c8fb310527d15d666a58ab4661114",
  "DeviceName": "jd-win11-22h2-1.ludus.domain",
  "InitiatingProcessAccountDomain": "nt authority",
  "InitiatingProcessAccountName": "network service",
  "InitiatingProcessAccountSid": "S-1-5-20",
  "InitiatingProcessCommandLine": "svchost.exe -k NetworkService -p",
  "InitiatingProcessCreationTime": "2026-08-01T00:56:39.0752007Z",
  "InitiatingProcessFileName": "svchost.exe",
  "InitiatingProcessFileSize": 79920,
  "InitiatingProcessFileSize@odata.type": "#Int64",
  "InitiatingProcessFolderPath": "c:\\windows\\system32\\svchost.exe",
  "InitiatingProcessId": 1540,
  "InitiatingProcessId@odata.type": "#Int64",
  "InitiatingProcessIntegrityLevel": "System",
  "InitiatingProcessMD5": "8ec922c7a58a8701ab481b7be9644536",
  "InitiatingProcessParentCreationTime": "2026-08-01T00:56:34.7240107Z",
  "InitiatingProcessParentFileName": "services.exe",
  "InitiatingProcessParentId": 1084,
  "InitiatingProcessParentId@odata.type": "#Int64",
  "InitiatingProcessSHA1": "3f64c98f22da277a07cab248c44c56eedb796a81",
  "InitiatingProcessSHA256": "949bfb5b4c7d58d92f3f9c5f8ec7ca4ceaffd10ec5f0020f0a987c472d61c54b",
  "InitiatingProcessSessionId": 0,
  "InitiatingProcessSessionId@odata.type": "#Int64",
  "InitiatingProcessTokenElevation": "TokenElevationTypeDefault",
  "InitiatingProcessUniqueId": "9851624184872980",
  "InitiatingProcessVersionInfoCompanyName": "Microsoft Corporation",
  "InitiatingProcessVersionInfoFileDescription": "Host Process for Windows Services",
  "InitiatingProcessVersionInfoInternalFileName": "svchost.exe",
  "InitiatingProcessVersionInfoOriginalFileName": "svchost.exe",
  "InitiatingProcessVersionInfoProductName": "Microsoft® Windows® Operating System",
  "InitiatingProcessVersionInfoProductVersion": "10.0.22621.1",
  "IsInitiatingProcessRemoteSession": 0,
  "IsInitiatingProcessRemoteSession@odata.type": "#SByte",
  "LocalIP": "10.2.10.21",
  "LocalPort": 50334,
  "Protocol": "TcpV4",
  "RemoteIP": "203.0.113.10",
  "RemotePort": 80,
  "RemoteUrl": "http://ctldl.windowsupdate.com/msdownload/update/v3/static/trustedr/en/authrootstl.cab?e129dbb8d60525cc",
  "ReportId": 14416,
  "ReportId@odata.type": "#Int64",
  "Timestamp": "2026-08-01T09:28:25.0297813Z"
}

Detection Patterns #

Show All Detection Patterns

Common Indicators #

Positive field/value combinations most frequently checked by detection rules attached to this catalog entry, derived from cross-vendor predicate analysis. This is separate from Fields accounting, which also includes exclusions and counts distinct attached rules.

FieldKindValueRulesVendors
Category (kusto rule field)eqAzureFirewallApplicationRule2 ruleskusto
Category (kusto rule field)eqAzureFirewallDnsProxy1 rulekusto
ResourceType (kusto rule field)eqAZUREFIREWALLS2 ruleskusto
process_basename (kusto rule field)containsregsvr32.exe2 ruleskusto
process_basename (kusto rule field)containsrundll32.exe2 ruleskusto
QueryName (kusto rule field)is_not_null1 rulekusto
parent_process_basename (kusto rule field)containscmd.exe1 rulekusto
parent_process_basename (kusto rule field)containspowershell.exe1 rulekusto
parent_process_basename (kusto rule field)eqmsiexec.exe1 rulekusto

Detection Rules #

Full rule details for this catalog entry, including ATT&CK technique mappings and native queries →

Kusto #

References #